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You can set type attributes before you enter characters or
reset them to change the appearance of selected characters
in a type layer.

Before you can format individual characters, select them.
You can select one character, a range of characters, or all
characters in a type layer.

Note:

To quickly get up to speed with text-related Photoshop
features, see Add words to your picture.

Select characters

Select the Horizontal Type tool  or the Vertical
Type tool .

1

Select the type layer in the Layers panel, or click in
the text to automatically select a type layer.

2

Position the insertion point in the text, and do one
of the following:

Drag to select one or more characters.

Click in the text, and then Shift-click to select a
range of characters.

Choose Select > All to select all the characters in
the layer.

Double-click a word to select it. Triple-click a line
to select it. Quadruple-click a paragraph to select
it. Quintuple-click anywhere in the text flow to
select all characters in a bounding box.

To use the arrow keys to select characters, click

3
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Character panel and dynamic shortcuts
overview

The Character panel provides options for formatting
characters. Some formatting options are also available from
the options bar.

You can display the Character panel by doing one of the
following:

Choose Window > Character, or click the Character panel
tab if the panel is visible but not active.

With a type tool selected, click the Panel button  in
the options bar.

To set an option in the Character panel, choose a value
from the pop‑up menu on the right side of the option.
For options with numeric values, you can also use the up

in the text, and then hold down Shift and press
the Right Arrow or Left Arrow key. To use the
keys to select words, hold down Shift+Ctrl
(Windows) or Shift+Command (Mac OS) and
press the Right Arrow or Left Arrow key.

To select all the characters in a layer without
positioning the insertion point in the text flow, select
the type layer in the Layers panel, and then double-
click the layer’s type icon.

Note:

Selecting and formatting characters in a type layer
puts the Type tool into edit mode.

4
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and down arrows to set the value, or you can edit the
value directly in the text box. When you edit a value
directly, press Enter or Return to apply a value,
Shift+Enter or Shift+Return to apply a value and then
highlight the value just edited, or Tab to apply a value
and move to the next text box in the panel.

Character panel

A. Font Family B. Font Size C. Vertical Scale D. Set Tsume
option E. Tracking F. Baseline Shift G. Language H. Font
Style I. Leading J. Horizontal Scale K. Kerning 

Note:

Select Show Asian Text Options in the Type preferences for
the Set Tsume option to appear in the Character panel.

You can access additional commands and options in the
Character panel menu. To use this menu, click the triangle in
the upper right corner of the panel.

Dynamic shortcuts are keyboard shortcuts accessible from
the Character panel menu only when you are entering point
or paragraph type, when type is selected, or when the
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I‑beam is in text. Dynamic shortcuts are available for type
options such as Faux Bold, Faux Italic, All Caps, Small Caps,
Superscript, Subscript, Underline, and Strikethrough.

Dynamic shortcuts appear in the Character panel menu only when
you are entering point or paragraph type, when type is selected, or
when the I‑beam is in text.

Specify type size and color

The type size determines how large the type appears in the
image.

The default unit of measurement for type is points. One
PostScript point is equal to 1/72 of an inch in a 72‑ppi image;
however, you can switch between using the PostScript and
traditional definitions of point size. You can change the
default unit of measurement for type in the Units & Rulers
area of the Preferences dialog box.

The type you enter is rendered in the current foreground
color; however, you can change the color before or after you
enter type. When editing existing type layers, you can change
the color of individual, selected characters or of all type in a
layer.

Choose a type size
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Define the point size unit

In the Character panel or options bar, enter or select
a new value for Size .
To use an alternate unit of measurement, enter the
unit (in, cm, mm, pt, px, or pica) after the value in
the Font Size text box.

Note:

To change the unit of measurement for type, choose
Edit > Preferences > Units & Rulers (Windows) or
Photoshop > Preferences > Units & Rulers (Mac OS),
and choose a unit of measurement from the Type
menu.

1

Choose Edit > Preferences > Units & Rulers
(Windows) or Photoshop > Preferences > Units &
Rulers (Mac OS).

1

PostScript (72 points/inch)

Traditional (72.27 points/inch)

For Point/Pica Size, select from the following
options:

Sets a unit size
compatible for printing to a PostScript device.

Uses 72.27 points
per inch, as traditionally used in printing.

2

Click OK.3
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Change the type color

Change the color of individual letters

Do one of the following:
Click the Color selection box in the options bar
or Character panel, and select a color using the
Adobe Color Picker.

Use fill shortcuts. To fill with the foreground
color, press Alt+Backspace (Windows) or
Option+Delete (Mac OS); to fill with the
background color, press Ctrl+Backspace
(Windows) or Command+Delete (Mac OS).

Apply an overlay layer style to the type layer to
apply a color, gradient, or pattern on top of the
existing color. You can’t apply an overlay layer
style selectively; it affects all characters in the
type layer.

Click the foreground color selection box in the
toolbox, and select a color using the Adobe
Color Picker. Alternatively, click a color in the
Color panel, or the Swatches panel. If you use
this method to change the color of an existing
type layer, you must first select characters on
that layer.

1

Select the Horizontal Type tool .1

In the Layers panel, select the layer containing the
type.

2

In the document window, select the characters you
want to change.

3
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Text treatments in the Character panel

Underline or strike through text

You can place a line under horizontal type, or to the left or
right of vertical type. You can also place a line through
horizontal or vertical type. The line is always the same color
as the type color.

In the options bar at the top of the work area, click
the color swatch.

4

In the Adobe Color Picker, locate the color range you
want using the triangle sliders on the color spectrum
bar, and then click the desired color in the color field.
The color you select appears in the top half of the
color swatch in the Adobe Color Picker. The original
color remains in the bottom half.

5

Click OK. The new color replaces the original color in
the options bar and in the selected characters.

Note:

You won’t see the new color in the characters until
you deselect them or select something else.

6

Select the type you want to underline or strike
through.

To underline horizontal type, click the Underline
button  in the Character panel.

To apply an underline to the left or right of
vertical type, choose Underline Left or Underline

1
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Apply all caps or small caps

You can enter or format type as uppercase characters, either
all caps or small caps. When you format text as small caps,
Photoshop automatically uses the small‑cap characters
designed as part of the font, if available. If the font does not
include small caps, Photoshop generates faux small caps.

Regular capital letters (top) compared to
small‑cap letters (bottom)

Right from the Character panel menu. You can
apply an underline to the left or right, but not to
both sides. A check mark indicates that an
option is selected.

Note:

The Underline Left and Underline Right options
appear in the Character panel menu only when a
type layer containing vertical type is selected. When
working with vertical Asian type, you can add an
underline on either side of the type line.

To apply a horizontal line through horizontal
type or a vertical line through vertical type, click
the Strikethrough button  in the Character
panel. You can also choose Strikethrough from
the Character panel menu.
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Specify superscript or subscript characters

Superscript and subscript text (also called superior and inferior
text) are reduced‑size text that is raised or lowered in
relation to a font’s baseline. If the font does not include
superscript or subscript characters, Photoshop generates
faux superscript or subscript characters.

Character styles

A character style includes character formatting attributes,
and can be applied to characters, a paragraph, or even a
range of paragraphs. You can create Character styles and

Select the type you want to change.1

Do one of the following:
Click the All Caps button   or the Small Caps
button  in the Character panel.

Choose All Caps or Small Caps from the
Character panel menu. A check mark indicates
that the option is selected.

2

Select the type you want to change.1

Do one of the following:
Click the Superscript button  or the Subscript
button  in the Character panel.

Choose Superscript or Subscript from the
Character panel menu. A check mark indicates
that the option is selected.

2

Format characters in Photoshop https://helpx.adobe.com/photoshop/using/formatting-characters.html

10 of 14 3/1/18, 9:49 AM



then apply them later.

Choose Window > Character Styles to open the Character
Styles panel. 

To apply a character style, select the text or text layer
and click a character style.

Type styles are hierarchical: Manual overrides supersede any
applied character styles, which in turn replace applied
paragraph styles. This hierarchical approach lets you
combine the efficiency of styles with the flexibility to
customize your designs.

For a video overview, see Paragraph and Character Styles in
Photoshop  by Julieanne Kost.

Create a character style

If you want to base a new style on the formatting of
existing text, select that text.

1. 

Choose New Character Style from the Character Styles
panel menu.

2. 

Note:To create a style without first selecting text, click the
Create New Style icon  at the bottom of the Character Styles
panel. To edit a style without applying it to text, select an image
layer, such as the Background.

Edit a character style

Double-click existing styles to edit them and update all
associated text in the current document. Changing the style
formatting updates all text to which the style has been
applied with the new format. 

To edit a character style, do the following:

Double-click the style in the Character Styles panel.1. 

To specify the formatting attributes, click a category2. 
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(such as Basic Character Formats) on the left, and specify
the attributes to add to the style.

When you’ve finished specifying the formatting
attributes, click OK.

3. 

Specifying default type styles | Creative Cloud
only

Current character and paragraph styles can be saved as type
defaults. These defaults are automatically applied to new
Photoshop documents and can also be applied to existing
documents that don't already contain type styles. For more
information, see Paragraph styles.

To save the current character and paragraph styles as the
type defaults, do any of the following:

Choose Type > Save Default Type Styles.

In the Character Styles or the Paragraph Styles panel,
choose Save Default Type Styles from the panel menu.

To apply the default Character and Paragraph styles to a
document:

Do any of the following:

Choose Type > Load Default Type Styles.

In the Character Styles or the Paragraph Styles
panel, choose Load Default Type Styles from the
panel menu.

1

If you are loading the default type styles into a
document that already has an existing type style, the
Import Paragraph Styles dialog box appears. You can
choose whether or not to replace the existing type
style with the default type style.

2
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